Linux en Espanol
 
Instalación de Apache y PHP (tema #953)
Publicar nuevo tema  Responder al tema    Foros de discusión -> Servidores y Servicios
Autor Mensaje
el_pollo
Forista
Registrado: 2003-11-13
Mensajes: 52

Publicado: 2003-12-04 01:05:01    Asunto: Instalación de Apache y PHP

Tengo instalado apache 1.3.29 en RedHat 7.2, necesito instalar php 4.3.2, pero cuando trato de instalarlo me marca un error con el apxs de apache, me dice que debo tener dos modulos cargados, mod_core y mod_so en apache, cuando consulto esto con httpd -l em mod_so no me apacere, ú Cómo puedo hacer para integrar este modulo a apache?
maestro
Forista


Registrado: 2003-11-26
Mensajes: 1140

Publicado: 2003-12-04 04:18:31    Asunto:

Si tienes apache instalado de paquetes DEB o RPM, tienes que hacer lo mismo con el PHP. De lo contrario instala ambos del código fuente de la siguiente manera:

Instala Apache:
[code:1:77f21f4bc7]tar -zxf httpd-2.0.47.tar.gz
cd httpd-2.0.47
./configure --enable-so
make
make install
cd ..[/code:1:77f21f4bc7]

Instala PHP:
[code:1:77f21f4bc7]tar -jxf php-4.3.2.tar.bz2
cd php-4.3.2
./configure --with-apxs2=/usr/local/apache2/bin/apxs
make
make install
cp php.ini-dist /usr/local/lib/php.ini[/code:1:77f21f4bc7]

Mira esto para más referencia:
http://www.linuxespanol.com/tema126.html
el_pollo
Forista
Registrado: 2003-11-13
Mensajes: 52

Publicado: 2003-12-04 16:18:16    Asunto: Terminado

Listo Maestro, tenía instalado apache 1.3.29, pero me he actualizado a apache 2.0.47, hasta ahora todo va bien, le he instaldo el php 4.3.2 y sin problemas, ya tengo funcionando squirrelmail y hasta ahorita cero problemas.

Me gustaría hacer una aclaración. Nunca se menciona la parte del prefix para hacer la instalación de los paquetes. Es algo util creo yo que apenas comienzo en esto, por ejemplo, ahora enmi sistema tengo dos versiones de apache en dos directorios distintos, así que para instalarlo sobre el apache dos hice:
prefix="/usr/local/myweb"

./configure --prefix=$prefix --withapxs2=/usr/local/myweb/bin/apxs

Y listo tengo instalado sobre el apache2.
ricardo_peru
Forista
Registrado: 2004-06-22
Mensajes: 1

Publicado: 2004-06-22 04:03:50    Asunto: ey me resulto este codigo....pero...

[quote:42ca51a769="maestro"]Si tienes apache instalado de paquetes DEB o RPM, tienes que hacer lo mismo con el PHP. De lo contrario instala ambos del código fuente de la siguiente manera:

Instala Apache:
[code:1:42ca51a769]tar -zxf httpd-2.0.47.tar.gz
cd httpd-2.0.47
./configure --enable-so
make
make install
cd ..[/code:1:42ca51a769]

Instala PHP:
[code:1:42ca51a769]tar -jxf php-4.3.2.tar.bz2
cd php-4.3.2
./configure --with-apxs2=/usr/local/apache2/bin/apxs
make
make install
cp php.ini-dist /usr/local/lib/php.ini[/code:1:42ca51a769]

Mira esto para más referencia:
http://www.linuxespanol.com/tema126.html[/quote:42ca51a769]

ey e probado este codigo en red hat 8.0 y logre instalar apache2.0 y php4.0 pero quisiera saber como le hago ahora para instalar el mysql y usarlo desde php
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-09-16 19:55:17    Asunto:

Nota: Para habilitar SSL (https) agregar [b:35a4c0ba7e]--enable-ssl=shared[/b:35a4c0ba7e] al ./configure
kade
Forista
Registrado: 2006-03-19
Mensajes: 2

Publicado: 2006-03-19 18:55:44    Asunto: como actualizo php y mysql

[size=24:799bc35070][color=blue:799bc35070]ke tal como se actualiza php y mysql ..saludos..[/size:799bc35070][/color:799bc35070]

Amigo, si tienes una duda primero revisas dudas frecuentes y revisas en los post anteriores (e incluso revisas usando un buscado). Si no encuentras respuesta entonces abres un nuevo post.

TheBalrog.





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries