Linux en Espanol

ATENCION: Estamos trabajando en el nuevo foro. De momento, solo se pueden ver temas existentes y no todo funciona. Volvemos pronto!

 
Guardar tabla de rutas. ayuda pls (tema #2786)
Publicar nuevo tema    Responder al tema    Foros de discusión -> Linux General
Autor Mensaje
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-03 14:15:27    Asunto: Guardar tabla de rutas. ayuda pls

HOla a todos
tengo montado un Red Hat 7.3 conectado con dos tarjetas de red una al router y otra a una red interna.
Tengo puesto el apache con el tomcat y me sucede algo muy raro raro raro. El tema es que funciona(se ve desde la IP del ADSL externa) un rato si un rato no. y lo más raro es que para que vuelva a funcionar y que pueda acceder desde internet lo unico q tengo que hacer es poner route.
Es como si no almacenara las tablas
que puedo hacer?

gracias por anticipado
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-03-04 04:04:19    Asunto:

El comando "route" por sí solo, simplemente te muestra las rutas pero no afecta la configuración, salvo que hagas n [b:e6c8c9766f]route add[/b:e6c8c9766f] o [b:e6c8c9766f]route del[/b:e6c8c9766f]

No tendrás un problema de cableado ? O de interferencia en tu cable de red ? Lo estarás pasando cerca de un cableado eléctrico o fuente de alimentación ? Algunas ideas nomás.
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-04 10:17:41    Asunto: no pasa cerca de lo de los cables

El tema es que de vez en cuando se pierde no aguanta mas de 5 minutos viendose el servidor web desde internet como si perdiera esas rutas
ahora he probado a meterlas dentro del static-routes
pero sigue sin quedarse un rato funcionando

alguna sugerencia mas?

gracias
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-04 10:46:36    Asunto: una solucion MUY í?APA

pfff hola a todos de momento lo he solucionado
pero claro es lo más ñapas que he visto desde el desarrollo del word 1.0 :lol:

Lo que he hecho es poner un cron cada 5 minutos que ejecute el comando route pfff :roll:
rula pero claro tiene que haber otra cosa que hacer digo yo
a ver esos gurus!

gracias
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-03-04 20:04:04    Asunto:

Ahí hay algo raro. Puedes fijarte en /var/log/messages ? Se loguea algo cuando pierde la ruta ?
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2004-03-05 14:49:05    Asunto: red hat

Que le habreis hecho a esa red hat para que pierda la conexion cada poco. Quiza estaría bien que hicieras un upgrade de tu distro, o que instalases fedora que es la 10.0. Cuando dices que se deja de ver la web, pierdes internet? Es decir, te quedas sin conexion, o es que solo casca el servidor web? Y el router? Tiene internet este mientras?

A ver si podemos ir descartando cosas, como un ataque cada 5 minutos, quiza alguien tenga uno tambien en su cron xD. Es matematico? es decir, es cada 5 minutos exactos que te quedas sin web?

Un saludo y suerte
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-08 12:18:19    Asunto: sigue igual esto jop

Pues el tema es que se pierde el acceso a la WEB desde fuera osea desde Internet por el ADSL. desde dentro en la red local funciona todo el rato no se cae ni patras la web
pero desde fuera osea poniendo la direccion del ADSL a la que estan redireccionados los puertos a esta maquina de dentro de la red esa es la que se pierde cosa bastante rara la verdad.
No se donde se pueden poner las rutas a pelo para que no las pierda.
En el var/log/message lo unico que veo raro es que hace mucho alusion a namequery.c o algo asi,
creeis que puede tener que ver?
estoy atacado esto es raro raro raro

gracias!
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-03-08 17:01:05    Asunto:

No será la configuración del dhcp que renueva la IP constantemente ? Copia aquí la configuración de tu cliente de dhcp por favor. Gracias.
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2004-03-09 05:22:46    Asunto: pregunta

No respondiste a mi pregunta. Pierde solo el servidor web, o pierde completamente la conexion a internet ese equipo?

Si solo pierde el servidor web desde fuera, y sigue teniendo internet, es por tu router, no cabe duda.

Un saludo.
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-09 07:32:03    Asunto: seguimos =

A ver la dirección IP es fija no tengo puesto DHCP
cuando pierde la conexión externa pierde cualquier salida desde ese ordenador hacia afuera osea que no reconoce la ruta a la que tiene que enviar los paquetes cuando salen a Internet, pero en la red interna sigue funcionando.

El tema es que cuando pones route le cuesta siempre un poco que salgan las rutas cosa extraña.
Quizas deberia meter las rutas que salen ahora mismo cuando pongo route en el etc/sysconfig/networking/ en cada uno de los interfaces de red?
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2004-03-09 15:25:34    Asunto: olvidalo

Olvidalo entonces, eso tiene que ser de tu router, que esta como las maracas de machin, o de tu cable, o sabe dios de que.
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-03-09 19:53:00    Asunto:

Eso, no será un problema de cableado ? Has probado conectar otro ordenador al mismo cable ?
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-03-10 08:14:48    Asunto: lo probe

He probado con otros cables y todo sigue = es como si perdiera las rutas sobre todo la de por defecto para cuando tiene que responder a paquetes que le vienen de fuera desde el router, alguno sabeis donde se meteria las rutas para que al arrancar las cogiera automáticamente?
en el sysconfig/networking-script?

gracias!
el_pollo
Forista
Registrado: 2003-11-13
Mensajes: 52

Publicado: 2004-03-11 17:58:12    Asunto:

Fácil.

En etc/sysconfig se encuentra el archivo static-routes, añadelas y asunto arreglado.
linuxero
BOFH


Registrado: 2004-01-09
Mensajes: 2871

Publicado: 2004-03-11 18:04:08    Asunto:

Buen punto. El tema es por qué está "perdiendo" la ruta...





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries