Linux en Espanol
 
problema con ide codelite no aparece xterm al ejecutar (tema #25077)
Publicar nuevo tema  Responder al tema    Foros de discusión -> Programación
Autor Mensaje
harofenix
Forista
Registrado: 2014-12-06
Mensajes: 39

Publicado: 2014-12-06 22:52:18    Asunto: problema con ide codelite no aparece xterm al ejecutar

Que tal gente de linux en espa?ol, este es mi primer post, espero me puedan auxiliar / acesorar con mi peque?o problemita. He comprado un curso en UNDEMY para programacion en C, en dicho curso utilizan codlite, por lo tanto, me di a la tarea de instalar dicho IDE en mi elementary OS, lo hice desde el centro de software y todo bien, he logrado escribir, compilar el codigo en C (haciendo uso de GCC, en la configuracion de codelite) sin embargo, al momento de darle ejecutar no se abre xterm, es decir, no sucede nada, dentro de la pesta?a "Trace" me aparece los siguientes mensajes:

15:50:18: Error: XML parsing error: 'no element found' at line 1
15:50:18: INFO: Found 13 system include files. 2 needed to be parsed. Stored 176 new tags to the database
15:50:23: Launching console: /usr/lib/codelite/codelite_xterm '"./HelloWorld"' 'sleep 106641'
15:50:24: Failed to allocate console for debugger, do u have Xterm installed?

nota: tengo xterm instalado correctamente en su ultima version. he anexado system("PAUSE")
la compilacion termina de maner exitosa con 0 error y 0 advertencias

En mi pesta?a de salida me aparece este mensaje de todo bien:
Current working directory: /home/harofenix/Documentos/workspacedeTestCodelite/helloWorldInc++/HelloWorld/Debug
Running program: /usr/lib/codelite/codelite_xterm './HelloWorld ' '/bin/sh -f /usr/lib/codelite/codelite_exec ./HelloWorld '
Program exited with return code: 0

Que es lo que tengo que hacer para poder ver la ejecucion de mis programas en la terminal? espero sus prontas respuestas gracias. !
rafaxdrake
Forista


Registrado: 2004-02-21
Mensajes: 3928

Publicado: 2014-12-07 11:14:48    Asunto:

La ejecuci?n te lo est? preguntando, f?jate en la l?nea que dice: "do u have Xterm installed?" Por eso no hace nada, porque no la tienes instalada. Lo que tienes que hacer es instalar xterm o en el c?digo del programa cambiar xterm por la terminal que tengas instalada en tu linux o la que t? quieras que se use. Digo esto ?ltimo porque xterm es una terminal obsoleta y abandonada en desarrollo.

Si quieres aprender a programar, te recomiendo encarecidamente que leas e intentes comprender los mensajes que te env?a el sistema cuando ejecutas algo.
harofenix
Forista
Registrado: 2014-12-06
Mensajes: 39

Publicado: 2014-12-09 22:52:11    Asunto:

[quote:a4762c5656="rafaxdrake"]La ejecuci?n te lo est? preguntando, f?jate en la l?nea que dice: "do u have Xterm installed?" Por eso no hace nada, porque no la tienes instalada. Lo que tienes que hacer es instalar xterm o en el c?digo del programa cambiar xterm por la terminal que tengas instalada en tu linux o la que t? quieras que se use. Digo esto ?ltimo porque xterm es una terminal obsoleta y abandonada en desarrollo.

Si quieres aprender a programar, te recomiendo encarecidamente que leas e intentes comprender los mensajes que te env?a el sistema cuando ejecutas algo.[/quote:a4762c5656]

xterm si la tengo correctamente isntalada, sin embargo, ahora el mensaje de error en cuestion es otro, este:


16:44:20: Error: XML parsing error: 'no element found' at line 1
16:44:20: Symbols file loaded into OS file system cache (0 seconds)

alguna idea?
rafaxdrake
Forista


Registrado: 2004-02-21
Mensajes: 3928

Publicado: 2014-12-12 10:53:44    Asunto:

Pues entonces el que no ley? bien fui yo, menudo despiste, perdona.
rafaxdrake
Forista


Registrado: 2004-02-21
Mensajes: 3928

Publicado: 2014-12-12 10:57:11    Asunto:

Seg?n comentan por aqu? https://bugs.launchpad.net/ubuntu/+source/codelite/+bug/575635 es un error en el paquete codelite, pero ya se ha solucionado con su nueva versi?n. ?Has actualizado tu sistema?
harofenix
Forista
Registrado: 2014-12-06
Mensajes: 39

Publicado: 2014-12-12 22:04:19    Asunto: gracias por tus respuestas MI SOLUCION FUE:

[quote:4c9b2d2093="rafaxdrake"]Seg?n comentan por aqu? https://bugs.launchpad.net/ubuntu/+source/codelite/+bug/575635 es un error en el paquete codelite, pero ya se ha solucionado con su nueva versi?n. ?Has actualizado tu sistema?[/quote:4c9b2d2093]

Muchas gracias por las atentas respuetas, la verdad es que esta comunidad es genial, Finalmente me decante por regresar al sistema que hacia ya tiempo no utilizaba, Debian, esto debido a la gran desepcion que fue para mi la experiencia con elementary os FREYA la cual esta aun (y sobre todo en mi ultrabook) muy, pero muy, inestable, por tal, antier me di a la tarea (7:00 a.m.) de: DESCARGAR/ CREAR USB-LIVE / INSTALAR mi extraordinaria DEBIAN 7.7 (W.....), a su vez, batalle un poco con la red modificando el NetworkManager, sin embargo, todo bien, ahora estoy feliz dentro del KDE (pesadito pero agradable en mi monitor de 23.6 pulgadas(escritorio extendido con el peque;o monitor de mi ativ book 7 13,3 pulgadas)) y feliz con su estabilidad. aqui esta todo genial simplemente tuve que ir a la pagina oficial de code lite y segui estas instrucciones:
# apt-key adv --fetch-keys http://repos.codelite.org/CodeLite.asc

Ahora a?adir el repositorio a nuestro sources.list, ya sabes.

# nano /etc/apt/sources.list

y a?adir.

deb http://repos.codelite.org/debian/ wheezy contrib

Actualizamos e instalamos.

# apt-get update
# apt-get install codelite wxcrafter

los respositorios son lentos (perso muy seguros) quedo instalada la ultima version de codelite y aqu[i no tuve que hacer nada solomanete escribir codigo "build and run proyect" y listo !!

ahora lo que si es que el volumen quedo muy bajito (del sisetma en general ) pero bueno, ese es otro tema ! loll ahorita lo posteo
! saludos. !
rafaxdrake
Forista


Registrado: 2004-02-21
Mensajes: 3928

Publicado: 2014-12-12 22:23:29    Asunto:

Me alegro de que te haya ido bien al final. S?, desde luego con Debian mucho mejor que con esas distros, que son bombas de relojer?a. Saludos.





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries