Linux en Espanol
 
problemas con xdotool y xclip (tema #24970)
Publicar nuevo tema  Responder al tema    Foros de discusión -> Programación
Autor Mensaje
epicteto
Forista
Registrado: 2014-02-23
Mensajes: 29

Publicado: 2014-04-05 07:02:52    Asunto: problemas con xdotool y xclip

Hola

Estoy intentando hacer un peque?o programa que me automatice ciertas tareas que consisten en copiar el valor de ciertas variables de una rutina en Python, y pegarlas en otro programa.

Todo lo de Python me funciona bien. Para copiar y pegar el valor de las variables en otro sitio uso una combinaci?n de comandos xdotool (para mover el rat?n y pulsar combinaciones de teclas) y xclip para manejar el clipboard.

Tengo dos problemas. Xclip no me cambia el valor del clipboard, quiero decir que aunque vaya copiando y pegando cosas distintas siempre me pega lo mismo (a veces el primer valor dado, a veces el ?ltimo...) o sea, que el valor del clipboard no cambia. He metido entre comandos algunos delay y la instruccion:

"echo -n | xclip -selection clipboard"

que deber?a limpiar el portapapeles, pero no lo hace.

Y por otro lado, cuando ejecuto la rutina, la X se me queda "frita" y paralizada durante unos 7-10 segundos, no puedo hacer nada con el rat?n ...

?podeis ayudarme? Gracias





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries