Linux en Espanol
 
Se me tilda al bajar querer bajar resolucion pantalla (tema #24405)
Publicar nuevo tema  Responder al tema    Foros de discusión -> Soporte de Hardware
Autor Mensaje
Panchiroly
Forista
Registrado: 2012-05-04
Mensajes: 5

Publicado: 2012-05-04 14:52:42    Asunto: Se me tilda al bajar querer bajar resolucion pantalla

Buenas a todos los amigos del foro, tengo el problema al instalar un debian squeeze 64 bits en una pc con motherboard gigabyte GA-H61M-S2V-B3, con procesador core i7 la estoy usando con su placa de video onboard que toma del chipset intel H61 Express, les cuento que instale todo al pelo, pero tengo problemas en en entorno grafico (gnome) ya que cuando instale esto me tomo una resolucion alta 1024x768 y tengo como desbordado el monitor (lcd widescreen) quiero bajar la resolucion a 800x600 por ejemplo, lo hago por interface grafica en preferencias-monitor pero al bajar se me tilda la pc se reinicia y vuelve a entrar en la resolucion alta. Revise y no tengo generado el archivo xorg.conf. Que puedo hacer, hay algo manual por consola? es el driver de la placa o el monitor?. Muchas gracias desde ya.
Con el comando ldpci me arroja lo sgte:

00:00.0 Host bridge: Intel Corporation Sandy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
Subsystem: Giga-byte Technology Device d000
00:16.0 Communication controller: Intel Corporation Cougar Point HECI Controller #1 (rev 04)
Subsystem: Giga-byte Technology Device 1c3a
00:1a.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #2 (rev 05)
Subsystem: Giga-byte Technology Device 5006
Kernel driver in use: ehci_hcd
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 05)
Subsystem: Giga-byte Technology Device a002
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 1 (rev b5)
Kernel driver in use: pcieport
00:1c.4 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 5 (rev b5)
Kernel driver in use: pcieport
00:1d.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #1 (rev 05)
Subsystem: Giga-byte Technology Device 5006
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Cougar Point LPC Controller (rev 05)
Subsystem: Giga-byte Technology Device 5001
00:1f.2 IDE interface: Intel Corporation Cougar Point 4 port SATA IDE Controller (rev 05)
Subsystem: Giga-byte Technology Device b002
Kernel driver in use: ata_piix
00:1f.3 SMBus: Intel Corporation Cougar Point SMBus Controller (rev 05)
Subsystem: Giga-byte Technology Device 5001
Kernel driver in use: i801_smbus
00:1f.5 IDE interface: Intel Corporation Cougar Point 2 port SATA IDE Controller (rev 05)
Subsystem: Giga-byte Technology Device b002
Kernel driver in use: ata_piix
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

Muchas gracias.
Saludos
rafaxdrake
Forista


Registrado: 2004-02-21
Mensajes: 3928

Publicado: 2012-05-04 15:55:12    Asunto:

En una terminal como root ejecuta:

[code:1:417665512e]Xorg -configure[/code:1:417665512e]

Esto generar? un fichero xorg.conf en la carpeta de root. Ahora tienes que renombrarlo y ponerlo en su sitio. En la misma terminal ejecuta:

[code:1:417665512e]mv /root/xorg.conf.new /etc/X11/xorg.conf[/code:1:417665512e]
Panchiroly
Forista
Registrado: 2012-05-04
Mensajes: 5

Publicado: 2012-05-04 17:57:51    Asunto:

Muchas gracias Rafaxdrake por la respuesta, realize lo que me recomiendas como root pero me tira el siguiente error:

root@WRF2:~# Xorg -configure

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.

Elimino dicho archivo con:

rm /tmp/.X0-lock

y me tira este error:
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Muchas gracias.
Saludos.
Panchiroly
Forista
Registrado: 2012-05-04
Mensajes: 5

Publicado: 2012-05-07 14:27:43    Asunto:

Estimado, me loguie como root, pare el gmd3 ya que en el intento anterior me tiraba ese error porque no salia del modo grafico, ejecute comando Xorg -configure y realice la copia del archivo xorg.conf cuando realize CTRL+D se me tildo la pc y las luces del teclado parpadeaban no tube mas remedio que resetear la pc entrar a prueba de fallos y borrar el xorg.conf y volvio a entrar a modo grafico pero con el problema de resolucion de pantalla.
Estoy tratando de bajar la version del kernel: linux-image-3.2.0-0.bpo.2-amd64_3.2.15-1~bpo60+1_amd64.deb para instalar, mi pc posee el kernel: Linux PRUEBA 2.6.32-5-amd64 #1 SMP.....x86-64

Espero lograr instalar este kernel y que pueda bajar la resolucion de mi placa de video.
Muchas gracias.
TheBalrog
BOFH
Registrado: 2004-04-05
Mensajes: 3012

Publicado: 2012-05-07 20:31:02    Asunto:

[quote:45b86e7728="Panchiroly"]Estimado, me loguie como root, pare el gmd3 ya que en el intento anterior me tiraba ese error porque no salia del modo grafico, ejecute comando Xorg -configure y realice la copia del archivo xorg.conf cuando realize CTRL+D se me tildo la pc y las luces del teclado parpadeaban no tube mas remedio que resetear la pc entrar a prueba de fallos y borrar el xorg.conf y volvio a entrar a modo grafico pero con el problema de resolucion de pantalla.
Estoy tratando de bajar la version del kernel: linux-image-3.2.0-0.bpo.2-amd64_3.2.15-1~bpo60+1_amd64.deb para instalar, mi pc posee el kernel: Linux PRUEBA 2.6.32-5-amd64 #1 SMP.....x86-64

Espero lograr instalar este kernel y que pueda bajar la resolucion de mi placa de video.
Muchas gracias.[/quote:45b86e7728]

?Linux PRUEBA? Entonces no utilizas un kernel de stock sino uno modificado. Ser? que puede ser eso.
Panchiroly
Forista
Registrado: 2012-05-04
Mensajes: 5

Publicado: 2012-05-07 21:03:35    Asunto:

Pude solucionar el inconveniente al actualizar el kernel, estuvo rebelde mi debian para actualizarlo via comandos o consola, lo hice a traves de synaptic y al reiniciar con el nuevo kernel 3.2.0-0.bpo.2-amd64 #1...entro con resolucion alta pero sin desborde...espectacular.
Muchas gracias por sus aportes. Espero sirva a los demas.

Saludos a la comunidad! :D
Panchiroly
Forista
Registrado: 2012-05-04
Mensajes: 5

Publicado: 2012-05-15 13:31:28    Asunto:

Estimados, como puse en el mensaje anterior se me soluciono el problema del desborde con el nuevo kernel, pero ahora cuando apago la pc y la enciendo al entrar en el nuevo kernel no manda se?al al monitor, tengo que resetearla entrar en el kernel "viejo" reiniciar desde ahi y a veces entra con se?al y la mayoria de las veces no manda se?al al bootear con el kernel nuevo. Me recomendadon desactivar el splash en el grub lo hice pero nada no me soluciono. Muchas gracias.
Saludos.





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries