Linux en Espanol
 
Accediendo particiones Windows NTFS (tema #137)
Publicar nuevo tema  Responder al tema    Foros de discusión -> Estaciones de Trabajo
Autor Mensaje
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-04 19:58:06    Asunto: Accediendo particiones Windows NTFS

Hola. Soy novato al mundo de Linux. Acabo de instalarme Red Hat 9.0 en mi machine (hde1) tengo 3 discos. (C, D) y preparé uno especialmente para Linux. Hasta aqui todo bien. Y he grabado el lilo en floppy. Arranco por floppy. Y me carga las X (kde) todo perfecto. He creado 2 dir para "ver" los otros 2 discos y digo como SU, mount -t NTFS Casa I y me dice que el Kernel no es compatible. Tengo ya el nuevo kernel 2.4.22. Pero me da panico de tener que compilar el nuevo kernel. Hay otra forma que pueda visualizar mis otros 2 discos sin que tener que compilar el nuevo kernel?
Espero que haya alquien que entienda de esto :oops:
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-04 20:08:44    Asunto:

Claro que se entiende. No se trata de actualizar el kernel, sino de instalar el kernel con soporte de NTFS. En lugar de compilar el kernel, bájatelo en formato RPM de esta página:

http://linux-ntfs.sourceforge.net/info/redhat.html#inst1

Haz antes un [b:e5d5893435]uname -a[/b:e5d5893435] para bajar la versión que corresponde a tu kernel.
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-04 20:11:36    Asunto:

Me olvidaba , despues de instalar el RPM, cárga el módulo con:

[b:a82a557b64] /sbin/modprobe ntfs[/b:a82a557b64]
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-05 17:29:25    Asunto: funciona Casi ...Casi....pero no me reconoce mis HD´s !

Hola Thor. Antes que nada te quiero dar las gracias por tu gran ayuda... me he descargado el paquete. (RH9.9 2.4.20-8,athlon) He hecho cat /proc/filesystems. A mi me sale una lista algo más grande. He seguido todas las intrucciones y todo va bien hasta el momento que quiero montar mis discos, c y f. Me dice que no existen. joer... :( que puedes decir que pasa ahora (FYI hde es mi disco enchufado a una tarjeta raid) Espero que me puedas hechar de nuevo un cable? Muchas gracias :P
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-05 19:04:30    Asunto:

Cómo estas haciendo el mount ? Pásame por favor el comando que estas tecleando y el error que te esta dando, tal vez salga alguna idea.
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-05 23:57:25    Asunto: el comando que he usado para acceder mis otros 2 discos

Hola Thor. Aqui te paso el comando que estoy usando:
es el mismo que viene en el doc que me has pasado...
ahora si que ya no entiendo na de na... durante la instalacion me reconocio perfectamente mis 3 discos, y ahora ya no los ve? :(
sabes indicarme que hago mal?
muchas gracias,
paco

[root@localhost paco]# ls
casa-1 casa-2 Desktop evolution test
[root@localhost paco]# mount /dev/hdc casa-1 -t ntfs -r -o unmask=0222
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
[root@localhost paco]#
linuxespanol
BOFH


Registrado: 2003-10-21
Mensajes: 223

Publicado: 2003-11-06 00:02:51    Asunto:

El principal error es que te estas refiriendo a hdc como una unidad de disco cuando deberías estar indicando la partición específica que quieres montar. Si ese disco tiene solo una partición NTFS, entonces la partición es /dev/hdc1 o sea, la primera particion del disco hdc

Prueba [b:2ed01ace96]mount -t ntfs /dev/hdc1 /home/paco/casa-1[/b:2ed01ace96], a ver si le gusta... (o como sea la ubicación del directorio casa-1)
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-10 12:44:38    Asunto:

[size=9:b6ca22b070]Hola Thor. /Linux Español
Perdona por el retraso, pero he estado fuera...
Aqui va la prueba que hice y mira lo que me da..

[root@localhost /]# cd mnt
[root@localhost mnt]# ls
cdrom cdrom1 floppy
[root@localhost mnt]# mount -t ntfs /dev/hdc1 /home/paco/casa-1
mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

Aprovecho para ponerte el texto que me sale en el fichero "mesages"
/var/log/messages/
Nov 10 13:04:31 localhost kernel: NTFS driver v1.1.22 [Flags: R/O MODULE]
Nov 10 13:04:31 localhost kernel: ide-scsi: hdc: unsupported command in request queue (0)
Nov 10 13:04:31 localhost kernel: end_request: I/O error, dev 16:01 (hdc), sector 0
Nov 10 13:04:31 localhost kernel: NTFS: Reading super block failed
Nov 10 13:05:35 localhost kernel: ide-scsi: hdc: unsupported command in request queue (0)
Nov 10 13:05:35 localhost kernel: end_request: I/O error, dev 16:01 (hdc), sector 0
Nov 10 13:05:35 localhost kernel: NTFS: Reading super block failed
Nov 10 13:12:37 localhost su(pam_unix)[7196]: session closed for user root
[/size:b6ca22b070]
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-10 13:35:01    Asunto:

ide-scsi ? Aparentemente tienes la emulación de SCSI habilitada para hdc. Estas seguro que hdc es el disco donde tienes la partición NTFS y no un cdrom ?

Si estas seguro que hdc es el disco en cuestión y no un CDROM entonces deshabilítale la emulación de SCSI porque puede que esto te este causando problemas.

Para esto edita el archivo de configuración de tu lilo o grub (/boot/grub/grub.conf) y sácale la opción [b:a356ef30c3]ide-scsi[/b:a356ef30c3] en la linea [b:a356ef30c3]kernel[/b:a356ef30c3].

Luego reinicia el ordenador e intenta de nuevo.
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-10 16:28:05    Asunto: no existe ese fichero

[size=9:ce73a9b1e7]Hola thor.

Si, vamos veo 2 iconos para los dos cdroms en mi desktop, y funcionan bien, leo perfectamente la info de ambos cdroms...Lamentablemente ese fichero no está en (/boot/grub/grub.conf). Es más, he realizado una busqueda de dicho fichero por todo el hde y no lo encuentro.
Antes que nada te debo de comentar que mi lilo, esta un disco de arranque. Para tu info, tengo 2 discos y un tercero montado en una tarjeta raid. osea, c y f juntos en un cable Ide. y el tercer disco en una tarjeta raid.. igualmente ese fichero no existe en mi disco de arranque... heeelp, que frustración... que podemos hacer ahora? Te podria llamar para repasar unas cosas juntos... te importaria?
muchas gracias,
paco[/size:ce73a9b1e7]
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-10 16:38:34    Asunto:

Entonces si usas lilo el archivo es /etc/lilo.conf (o donde este en el diskette). Te he agregado a mi messenger, si ves que aparece un nombre extraño, ese soy yo.
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2003-11-10 18:40:12    Asunto: discos

Yo creo que lo primero que deberias hacer es intentar montar a pelo, que als maquinas ya son muy listas y poner mount /dev/hdc1 /discoduro (porejemplo)

Aun que sea ntfs te lo deberia de pillar igual

Otra opcion es que pongas cfdisk, y veas bien donde estan ubicadas esas particiones.

Un saludo
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-11 17:42:51    Asunto: He encontrado algo....

Hola Thor...
he encontrado un fichero en mi diskette (syslinux.cfg) que dice esto:
default linux
prompt 1
display boot.msg
timeout 100
label linux
kernel vmlinuz
append initrd=initrd.img hdc=ide-scsi root=/dev/hde1
quieres que quite la parte hdc=ide-scsi? :oops:
saludos,
Paco
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-11 18:14:50    Asunto: Re: discos

Hola friguare

Antes que nada te debo de comentar que aun no soy un "gran" experto en el tema de linux.. (solo para que lo sepas)
abro una terminal y me pongo como SU y digo cfdisk, y me dice que no encuentra el fichero. shit !
cuando hago mount /dev/hdc1 lo traga. Pero cuando abro el nautilus y veo un segundo disco montado me da un error y abre el contenido de mi hde1.
el error es: can´t find /dev/hdc1 in etc/fstab or /etc/mtab...
osea hacer lo a pelo no va bien.. shit !
gracias por tu input...
saludos,
paco
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-11 20:50:32    Asunto:

Paco, para poner un poco en escrito lo que habĺamos, recuerda lo siguiente:

[b:176c01f1f3]/dev/hda[/b:176c01f1f3] y [b:176c01f1f3]/dev/hdb[/b:176c01f1f3] son tus discos. Primario y secundario en la [b:176c01f1f3]primera[/b:176c01f1f3] controladora IDE, respectivamente.

[b:176c01f1f3]/dev/hdc[/b:176c01f1f3] y [b:176c01f1f3]/dev/hdd[/b:176c01f1f3] son tus CDROMS y lectora. Primario y secundario en la [b:176c01f1f3]segunda[/b:176c01f1f3] controladora IDE, respectivamente,

[b:176c01f1f3]/dev/hde[/b:176c01f1f3] es tu primer disco en tu [b:176c01f1f3]tercer[/b:176c01f1f3] controladora IDE, donde tienes instalado RedHat
[b:176c01f1f3]
/dev/hda1[/b:176c01f1f3] y [b:176c01f1f3]/dev/hdb1[/b:176c01f1f3] son tus particiones NTFS, correspondientes a la [b:176c01f1f3]primera[/b:176c01f1f3] (y única) partición en el [b:176c01f1f3]primer[/b:176c01f1f3] disco y [b:176c01f1f3]primera[/b:176c01f1f3] (y única) partición en el [b:176c01f1f3]segundo[/b:176c01f1f3] disco, respectivamente de la [b:176c01f1f3]primer[/b:176c01f1f3] controladora IDE

Por lo tanto, para montar tu NTFS sería:

[b:176c01f1f3]mount -t ntfs /dev/hda1 /home/paco/casa1
mount -t ntfs /dev/hda1 /home/paco/casa2[/b:176c01f1f3]

Por último, agrega las siguientes dos líneas a tu [b:176c01f1f3]/etc/fstab[/b:176c01f1f3] para definir los puntos de montado y poder crear el disco en el escritorio de KDE. De esta manera podrás montar y desmontar los discos desde la interfaz gráfica:

[code:1:176c01f1f3]/dev/hda1 /home/paco/casa1 ntfs defaults 0 0
/dev/hdb1 /home/paco/casa2 ntfs defaults 0 0
[/code:1:176c01f1f3]
fjalinux
Forista
Registrado: 2003-11-04
Mensajes: 11

Publicado: 2003-11-12 16:24:28    Asunto: Re: discos

Aqui os pongo el transscrito, caso que alguien tenga un problema similar con montar las particiones NTFS bajo RH 9.0 : :wink:

[size=9:b6b5922558]Linux-expert dice:
cual era tu problema ?
Linux-expert dice:
ok
Je je dice:
ya toy.....
Linux-expert dice:
ok
Je je dice:
bueno, vamos a ver...
Je je dice:
tengo una machine con 2 ide´s un ide tiene un lector y una grabadora y la otra ide tiene un disco de 120 gb y otro de 80 gb.. pero como me queria montar el linux me compré una tarjeta raid, la pinche y le puse un tercer disco de 40 gb todo dentro de una caja (aunque ahora esta bien llena...) pues bien, empeze con la instalacion del RH 9.0 y me deja elegir sobre cual queria instalarlo y me
Je je dice:
enseño todos los discos.. pues bien, como lo tenia reservado para esto elegí el hde
Linux-expert dice:
ok, o sea que tus discos son í?
Linux-expert dice:
/dev/hda Grabador de CD
Je je dice:
todo ha ido bien hasta el ultimo punto, en el cual me pregunto desde donde quiero hacer el boot. le dije para poner me lo en un floppt, asi tengo el disco, si lo meto arranco desde el disco y entro en linux si le quito arranco normal en mi WXP.
Linux-expert dice:
/dev/hda Lectora de CD /dev/hdb Grabadora de CD
Je je dice:
es así (bajo windows) a floppy c y f disco d y e son cd roms...
Linux-expert dice:
/dev/hdc Disco 1 /dev/hdd disco 2
Linux-expert dice:
/dev/hde Seria el disco en la placa RAID verdad ?
Je je dice:
yeah... correcto....
Linux-expert dice:
Y cuando instalaste RH en que disco le dijiste que lo instale ?
Je je dice:
poz en el que tenia reservado para el hde
Je je dice:
conectado mediante la tarjeta raid metido como ultimo de abajo en la misma caja...
Linux-expert dice:
Bien. En realidad podrías haber instalado GRUB en el primer disco, pero no importa
Linux-expert dice:
úQue pasa cuando arrancas con el diskette?
Je je dice:
ya eso me lo pense despues, pero bueno no pasa nada.. creo...
Linux-expert dice:
Igualmente lo puedes instalar despues
Linux-expert dice:
donde esta la falla entonces ?
Je je dice:
poz me da el prompt de linux, caso que quiera arrancar con una opcion, si pincho enter me sale una lista larga de comprobaciones y me arranca las x
Je je dice:
has visto mi ultimo mensaje a tí? en linuxespanol.com?
Linux-expert dice:
dejame ver
Linux-expert dice:
cual es tu usuario en linuxespanol ?
Je je dice:
fjalinux
Linux-expert dice:
estoy leyendo tu mensaje
Je je dice:

Linux-expert dice:
yo le sacaria el hdc=ide-scsi del kernel
Linux-expert dice:
esto habilita la emulación de SCSI y no tiene sentido para un HD
Linux-expert dice:
entonces el linux te arranca ?
Je je dice:
si perfectamente.. del fichero syslinux.cfg te refieres, verdad? Puedo comentarlo de alguna forma?
Linux-expert dice:
borra ese parametro simplemente
Je je dice:
o copio simplemente el fichero
Je je dice:
ah vale....
Linux-expert dice:
lo raro es el nombre del archivo
Linux-expert dice:
normalmente se llama lilo.conf o grub.conf
Linux-expert dice:
prueba reiniciarlo sin esa opcion en el inicio
Je je dice:
intento esto... arranco en linux y pongo mount -t ntfs /dev/hdc1 /home/je je/casa-1 verdad?
Linux-expert dice:
el menu de inicio es LILO o GRUB ?
Je je dice:
cuando arranco del disk?
Linux-expert dice:
claro
Linux-expert dice:
tiene que ser o uno o el otro
Je je dice:
poz lilo, pero te debo de confesar que no me he fijado bien, pero casi seguro que es lilo...
Linux-expert dice:
ok
Je je dice:
quito la opcion arranco y pruebo de hacer un mount... y te lo digo, fale?
Linux-expert dice:
entonces el problema que tienes en si es que no puedes montar el NTFS
Linux-expert dice:
claro
Linux-expert dice:
mount -t ntfs /dev/ntfs /mnt/ntfs
Linux-expert dice:
reemplaza /mnt/ntfs por el nombre del dir
Linux-expert dice:
donde lo quieras montar
Linux-expert dice:
Je je, me han llamado para un meeting corto
Je je dice:
no seria algo como /home/je je/casa-1
Linux-expert dice:
claro
Linux-expert dice:
pero asegurate que el directorio existe
Linux-expert dice:
estas en media hora ?
Je je dice:
claro ! okis... lo pruebo y hablamos en media hora.. si yo no me voy... estaré aqui toda la noche...
Je je dice:
hasta ahora... te esperaré...
Je je dice:
gracias
Linux-expert dice:
bien, excelente.
Je je dice:
ciao
Linux-expert dice:
mientras tanto, si te puedo pedir un favor
Je je dice:
dime..
Linux-expert dice:
haz un transcript de esta conversación en el foro
Linux-expert dice:
por si otro tiene la misma duda
Je je dice:
Ok ![/size:b6b5922558]
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-12 23:30:09    Asunto:

Gracias por la transcripción.
thor
BOFH


Registrado: 2003-10-31
Mensajes: 626

Publicado: 2003-11-12 23:37:07    Asunto:

Paco, quería agregar una cosa. Para que te deje montar los discos con tu usuario (no root) tienes que agregarle el UID de la siguiente forma:

[code:1:e9bab0c71f]/dev/hda1 /home/paco/casa1 ntfs user,uid=500 0 0
/dev/hdb1 /home/paco/casa2 ntfs user,uid=500 0 0[/code:1:e9bab0c71f]

Fíjate tu UID con el comando [b:e9bab0c71f]id[/b:e9bab0c71f]
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-07-02 22:55:18    Asunto:

hola quisiera saber si alguien sabe como instalar otro kernel pues me he bajado el 2.6.7 para redhat 9 por favor se los agradeszo si alguien me ayuda un manual pasdo por paso por favor.....
Dagger
Forista


Registrado: 2004-07-02
Mensajes: 261

Publicado: 2004-07-03 18:57:41    Asunto:

Pues le das a instalarlo como si fuera un programa normal, y cuando arranques tu pc te dara a elegir con que kernel quieres arrancar
elprimodemexico
Forista
Registrado: 2004-05-28
Mensajes: 7

Publicado: 2004-07-12 15:19:54    Asunto: Solo lo emula!

Bueno despues de horas y horas de tratar de recompilar el kernel lo he logrado, ahora decidi tratar con el catpive.

Instalo el captive desde el rpm -i captive.rpm, despues instalo el wine de la misma forma.

Despues procedo al montado [b:4ee8a45a14]mount -t captive-ntfs......(no recuerdo el comando).[/b:4ee8a45a14] y me manda un error dice que la particion de windows ya esta montada en [b:4ee8a45a14]/mnt/windows[/b:4ee8a45a14], así que procedo al desmontado [b:4ee8a45a14]/mnt/windows[/b:4ee8a45a14], listo!, ahora intento el montado de nuevo [b:4ee8a45a14]mount -t captive-ntfs......(no recuerdo el comando).[/b:4ee8a45a14] y listo este reconoce la partición de windows. Despues borrar ficheros, directorios para probar.

Despues reinicio la pc, entro a windows para ver los archivos los eliminados y siguen los muy mendigos siguen ahí!!!.

Reinicio la pc arranco Linux(Mandrake 9.1), entro a [b:4ee8a45a14]/mnt/docs[/b:4ee8a45a14] y aparece vacio(o sea no esta montado windows), lo vuelvo a montar pasa todo de nuevo. A que se debe?

NOTA: Por que aparentemente se borran los ficheros y cuando entro a windows siguen ahí, y úpor que se desmonta la partición de windows cada vez que reinicio?, úalguien que me sepa decir?

Gracias!
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-07-12 17:18:29    Asunto:

Soy un usurio nuevo de Linux, uso Fedora Core 1 junto con Window$ 98, por lo que ví de los comandos que anotaste estás tratando de borrar unos archivos desde Linux que están en la partición de Window$. La dficuldad puede radicar en que ambos sistemas de archivos (NTSF de Window$) y Ext3 (o cualquier otro) usan permisos en todos los archivos, si estás tratando de acceder archivos de un S.O. al otro lo más probable es que no te deje hacerlo. Hace unas semanas instalé un driver para NTSF al kernel 2.4.22 de Fedora Core 1 y sólo tengo acceso de sólo lectura a la partición NTSF. Probablemente esto sea lo que te sucede pero sólo estoy especulando en base a mi experiencia, seguramente alguien con más experiencia te podrá dar más luces en tu consulta
Scan
Forista
Registrado: 2004-06-26
Mensajes: 37

Publicado: 2004-07-17 03:09:42    Asunto:

compila el kernel que es menos quilombo
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-07-21 07:43:17    Asunto: Montar unidades con todos los permisos

hola, queria saber si me podrian ayudar con este problemita. Resulta q al montar mi unidad de disco, parece ser q no me deja el permiso de escritura, porque no me deja modificar nada. Espero una pronta ayuda, desde ya muchas gracias.

Nota: este es el comando q uso:
mount /dev/hda5 -t vfat /mnt
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-09-05 19:00:04    Asunto: ver NTFS en Fedora

[b:ca1ffd0bda] Hola....
Instale el RPM del kernel ke soporta montar un NTFS al cual llame "c", funciona bien kuando lo abro desde consola, pero kuando lo kiero abrir en modo grafico me da un error de permisos... trate de cambiarlo con chmod 777 c
pero me da este error chmod: cambiando los permisos de «c»: Sistema de ficheros de sólo lectura.

por lo ke he leido devo agregar una lines en fstab. he abierto el archivo (desde modo grafico )
y me da esto.

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

ahora... alguien me puede ayudar komo hacer accesible la lectuta del NTFS??? porfavoooooorrr ya he dado muchooo jugo.
muchas gracias...hasta luego :roll: :cry: [/b:ca1ffd0bda]
fjavier
BOFH


Registrado: 2004-06-22
Mensajes: 7112

Publicado: 2004-09-05 19:08:15    Asunto:

úQué versión de kernel estás usando? En los kernels 2.4.x la escritura en particiones NTFS se considera *PELIGROSO*, pero en los 2.6 ya funciona...
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-09-05 19:40:10    Asunto: NTFS

2.6.8-1.521
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-09-05 19:48:29    Asunto: otra cosa

Kuando instalo el pakete RPM kernel-ntfs-3.6.8-1.521.i686.rpm
lo instala y soporta la ntfs ..todo bien.. pero reinicio y chao... ya no soporta ntfs... komo lo hago???
fjavier
BOFH


Registrado: 2004-06-22
Mensajes: 7112

Publicado: 2004-09-05 20:41:27    Asunto:

úInstalas el paquete y ya está, no haces nada más? Si ese paquete trae un nuevo kernel, deberás reinstalar LILO o GRUB para que utilice el nuevo kernel...
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2004-09-14 01:30:43    Asunto: Accediendo particiones Windows NTFS

akabo de empezar con linux(aurox 9.2) y esto un poco perdido, e konseguido montar el disco ntfs, ke me aparezka komo montado en el usuario y en el root. al abrirlo komo administrador me deja leer los archivos ke kontiene esa particion pero no me deja alterar ningun archivo, y al entrar komo usuario no me deja ni leerlo. y la configuracion de permisos del disco no me deja alterarla desde ninguna cuenta
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2004-09-14 07:26:09    Asunto: modprobe

Pues puedes probar a poner:

[code:1:9b0f273eb4] modprobe ntfs [/code:1:9b0f273eb4]

Y prueba a ver si ya te deja escribir en las particiones. Seguramente ya tengas compilado como modulo el soporte ntfs y no lo tienes cargado.
astuntxirri
Forista
Registrado: 2004-09-14
Mensajes: 1

Publicado: 2004-09-22 22:11:41    Asunto: modprobe ntfs

he vuelto a quitar todo el montaje del disco1 ntfs y seguido de reiniciar he vuelto a hacer el montaje, pero ahora aparte de solo tener acceso de lectura no me deja ver nada en la paleta de preferencias me dice que las preferencias del disco1 no han podido ser determinadas...
conlo que no se ke mas hacerle mi archivo fstab esta asi


LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda1 /mnt/disco1 ntfs user,gid=astun 0 0

tambien tengo otro disco en ntfs que seria la siguiente linea(linea sin insertar 2ªproblema)

/dev/hdd1 /mnt/disco2 ntfs user,gid=astun 0 0

pero al iniciar el linux me da error diciendo ke el sistema ntfs no esta soprotado por el nucleo.
espero que alguno me pueda ayudar kon estos dos problemas ke me iimpiden compartir datos de un sistema a otro
friguare
BOFH


Registrado: 2003-11-05
Mensajes: 4517

Publicado: 2004-09-23 10:59:32    Asunto: ntfs

Es que vamos a ver, si tu nucleo es inferior a 2.6 a no ser que tengas instalado captive, no podrás escribir en las particiones ntfs. Que nucleo estas usando? Tienes captive instalado?
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2005-03-12 02:14:54    Asunto: Montar particion FAT32

Mi caso es diferente. Yo quiero montar una particion fat32 en RH9 pero me sale un mensaje. Primero les digo que hice:
- Edite /etc/sftab ingrese esta linea :
/dev/hda2 /mnt/windows vfat noauto,owner,users 0 0
(Tengo un solo disco duro que lo he dividido en 3 partes,
windows-datos-linux, siendo la mas grande "datos" en
fat32)

- luego hice una carpeta en /mnt y la llame windows/ osea
/mnt/windows

- borre el hdc= scsi (algo asi) de el grub y reinicie

- De regreso me bota el sgte mensaje:

[root@localhost root] mount -t vfat /dev/hda2 /mnt/windows[/size]
mount: tipo de sistema de ficheros incorrecto, opcion incorrecta, superbloque incorrecto en /dev/hda2, o numero de sistemas de ficheros montados excesivo
(aren't you trying to mount an extended partition, instead of some logical partition inside?)

acabo de migrar de mandrake 10.1 que daba muchos problemas... los drivers no compilaban, su networking deja mucho que desear, habia que hacerle un "mandrake" para entrar a la cuenta root ya que solo se usa el SU de consola, entre muchas otras cosas. El unico problema con Redhat 9 es este... que no puedo montar mi particion

agradecere todo tipo de ayuda
saludos
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2005-03-12 02:20:02    Asunto: correccion

el comando es este:

mount -t vfat /dev/hda2 /mnt/windows


nota: ese [/size] que aparece es el tamaño de letra que queria ponerle al mensaje y olvide borrar :D

saludos :wink:
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2005-03-16 22:15:27    Asunto: problema solucionado

Bueno... agradecerles por la ayuda inexistente que me dieron esta vez( solo esta vez ), gracias a ello solucione mi problema. En el comando no es:

mount -t vfat /dev/hda2 /mnt/windows

realmente deberia ser:

mount -t vfat /dev/hda5 /mnt/windows

y funcionara aunque no editen el fstab solo que tendran que ejecutar el que hacerlo cada vez que lo necesiten. Y por ahi vi en este foro como acceder sin muchos rodeos a una particion windows solo con dos clicks en un acceso directo que tienen que configurar.

en el caso de las Memorias flash por USB que trabajen con la tecnologia PLUG N' PRAY de mocosoft el comando seria:

mount -t vfat /dev/sda1 /mnt/usb

Si es un lector de tarjeta flexible, tendra muchas ranuras por lo que el comando solo variara en el numero que acompaña a "sda" pudiendo ser 2,3,4,5,etc dependiendo del numero de ellas.

Espero que esto les ayude...
Salu2
Anonymous
Forista
Registrado: 2003-10-21
Mensajes: 11749

Publicado: 2005-03-16 22:23:41    Asunto: P.D

Queria agregar que por experiencia propia... si su gestor de arranque es grub, y siguieron ese consejo de borrar " hdc= scsi "... NO LO HAGAN!!! Les causara un Kernel Panic si se les ocurre compilar su kernel y borraron el susodicho argumento. En un primer momento si lo borran no pasa nada, puede estar asi toda la vida y funcionaa normal, el asunto es cuando se les ocurre compilar su kernel y se olvidaron de escribir nuevamente el HDC ese...

Salu2
Draka
Forista
Registrado: 2005-04-05
Mensajes: 28

Publicado: 2005-04-05 02:47:54    Asunto: Que bien

Gracias, solo me inscribi al foro para agradecer la colaboracion.

Es que SuSe se le dio por ya no reconocer las particiones ntfs, y no sabia que hacer.

Como no he podido hacer que el berraco modem funcione, tonces toca navegar por win, y los programas para suse estaban bloqueados, pero bueo, me alegra que existan foros de este indole
Draka
Forista
Registrado: 2005-04-05
Mensajes: 28

Publicado: 2005-04-09 17:56:13    Asunto:

Me respondo.
El problema era que como se apago mal el PC se daño algo en el disco duro, creo que era la tabla de asiganacion, Programas como Partition Magic 8.1 lo detectan como dañado.
Pero no se preocupen ya se arreglo con otra aplicacion de win.
Tambien de particiones no me acuerdo el nombre pero muy buena.

Pegunta: hay algo para arreglar en Linux?
Jam_pzo
Forista


Registrado: 2005-04-14
Mensajes: 24

Publicado: 2005-04-14 00:54:37    Asunto:

yo tambien soy novato en linux, primera vez que lo instalo de hecho, pero instale FC3, como podria hacer para ver mis particiones FAT32 o NTFS en este sistema???, igual?
por favor, agradezco sus respuestas..
crower
Forista
Registrado: 2006-05-03
Mensajes: 1

Publicado: 2006-05-03 14:50:25    Asunto:

hola yo tambien soy nuevo en el mundo de linux y queria saber como veo la particion NTFS EN MANDRAKE 10
cnsey.chile
Forista
Registrado: 2006-08-14
Mensajes: 1

Publicado: 2006-08-14 06:17:47    Asunto:

hola soy novato en linux pero tenia el mismo problema con montar la particion ntfs y bueno les agradesco por haber respondido a mi pregunta sin tener que hacerla... :D
por si acaso aqui esta la direccion donde pueden encontrar las actualizaciones a los kernels: http://www.linux-ntfs.org
ojala les sea de ayuda.





La marca registrada Linux (R) se usa siguiendo la sublicensia obtenida del "Linux Mark Institute",
el LICENCIATARIO exclusivo de Linus Torvalds, propietario de la marca en EEUU y otros países
The registered trademark Linux (R) is used pursuant to a sublicense from the Linux Mark Institute,
the exclusive LICENSEE of Linus Torvalds, owner of the mark in the U.S. and other countries